# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\<manufacturer>([^<]*)<\\/manufacturer>)(\s*)(\<item_category>)(?:\2\s*)?([^<]*)(<\\/item_category>)/$1$2$3$4$5$6/gmi;t' <<< "<vehicle>
<manufacturer>JCB</manufacturer>
<item_category>JCB Tractors</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Digger</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Caterpillar Digger</item_category>
</vehicle>"