const regex = /(\<manufacturer>([^<]*)<\/manufacturer>)(\s*)(\<item_category>)(?:\2\s*)?([^<]*)(<\/item_category>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\<manufacturer>([^<]*)<\\\/manufacturer>)(\\s*)(\\<item_category>)(?:\\2\\s*)?([^<]*)(<\\\/item_category>)', 'gmi')
const str = `<vehicle>
<manufacturer>JCB</manufacturer>
<item_category>JCB Tractors</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Digger</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Caterpillar Digger</item_category>
</vehicle>`;
const subst = `$1$2$3$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);