use strict;
my $str = '<vehicle>
<manufacturer>JCB</manufacturer>
<item_category>JCB Tractors</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Digger</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Caterpillar Digger</item_category>
</vehicle>';
my $regex = qr/(\<manufacturer>([^<]*)<\/manufacturer>)(\s*)(\<item_category>)(?:\2\s*)?([^<]*)(<\/item_category>)/mip;
my $subst = '$1$2$3$4$5$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";