re = /(\<manufacturer>([^<]*)<\/manufacturer>)(\s*)(\<item_category>)(?:\2\s*)?([^<]*)(<\/item_category>)/mi
str = '<vehicle>
<manufacturer>JCB</manufacturer>
<item_category>JCB Tractors</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Digger</item_category>
</vehicle>
<vehicle>
<manufacturer>Caterpillar</manufacturer>
<item_category>Caterpillar Digger</item_category>
</vehicle>'
subst = '$1$2$3$4$5$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result