$re = '/^\d*(\d)\1{3}\d*$/m';
$str = 'Thnx Chappell for your feedback, i have to block phone number like :
0600000450
0511111320
0425888888
123
123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);