re = /^\d*(\d)\1{3}\d*$/m
str = 'Thnx Chappell for your feedback, i have to block phone number like :
0600000450
0511111320
0425888888
123
123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end