#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\S*\s)(?!.*?(.)\1{2}).{14,}\.$"
Local $sString = "One two three four." & @CRLF & _
"OOOne two thee four." & @CRLF & _
"One two thee fffour." & @CRLF & _
"One two three four" & @CRLF & _
"One two three." & @CRLF & _
"Onetwothreefour."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")