$re = '/^(?=\S*\s)(?!.*?(.)\1{2}).{14,}\.$/m';
$str = 'One two three four.
OOOne two thee four.
One two thee fffour.
One two three four
One two three.
Onetwothreefour.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);