import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\S*\\s)(?!.*?(.)\\1{2}).{14,}\\.$";
final String string = "One two three four.\n"
+ "OOOne two thee four.\n"
+ "One two thee fffour.\n"
+ "One two three four\n"
+ "One two three.\n"
+ "Onetwothreefour.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}