using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\S*\s)(?!.*?(.)\1{2}).{14,}\.$";
string input = @"One two three four.
OOOne two thee four.
One two thee fffour.
One two three four
One two three.
Onetwothreefour.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}