using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[fontSize=(\d+)\]";
string input = @"Lorem ipsum dolor sit amet, [b]consectetur adipisici elit[/b], sed eiusmod tempor incidunt ut labore et [fontSize=12]dolore [/fontSize=12] magna aliqua";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}