const regex = /\[fontSize=(\d+)\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[fontSize=(\\d+)\\]', '')
const str = `Lorem ipsum dolor sit amet, [b]consectetur adipisici elit[/b], sed eiusmod tempor incidunt ut labore et [fontSize=12]dolore [/fontSize=12] magna aliqua`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}