re = /\[fontSize=(\d+)\]/
str = 'Lorem ipsum dolor sit amet, [b]consectetur adipisici elit[/b], sed eiusmod tempor incidunt ut labore et [fontSize=12]dolore [/fontSize=12] magna aliqua'
# Print the match result
str.match(re) do |match|
puts match.to_s
end