package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[fontSize=(\d+)\]`)
var str = `Lorem ipsum dolor sit amet, [b]consectetur adipisici elit[/b], sed eiusmod tempor incidunt ut labore et [fontSize=12]dolore [/fontSize=12] magna aliqua`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}