using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#=\d{1,3}";
string substitution = @"";
string input = @"Text #=1 #=12 #=123 #=1234";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}