use strict;
my $str = 'Text #=1 #=12 #=123 #=1234';
my $regex = qr/#=\d{1,3}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";