const regex = /#=\d{1,3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#=\\d{1,3}', 'g')
const str = `Text #=1 #=12 #=123 #=1234`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);