$re = '/#=\d{1,3}/';
$str = 'Text #=1 #=12 #=123 #=1234';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;