using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([\S]+)\b";
string input = @"Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
Local ,residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...,u
Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}