import re
regex = re.compile(r"\$([\S]+)\b")
test_str = ("Local $residents o1__have called g__in o22__with reports...,u \n"
"Local ,residents o1__have called g__in o22__with reports...$u \n"
"Local ,residents o1__have called g__in o22__with reports...,u \n"
"Local ,residents o1__have called g__in o22__with reports...,u \n"
"Local $residents o1__have called g__in o22__with reports...,u \n"
"Local ,residents o1__have called g__in o22__with reports...$u \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")