// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$([\S]+)\b").unwrap();
let string = "Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
Local ,residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...,u
Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}