$re = '/\$([\S]+)\b/';
$str = 'Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
Local ,residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...,u
Local $residents o1__have called g__in o22__with reports...,u
Local ,residents o1__have called g__in o22__with reports...$u
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);