$re = '/replace[d]?([A-Z a-z 0-9]+)with([A-Z a-z 0-9]+)/m';
$str = 'replaceorangeswithapples
replacebluewithred
replacecarswithbuses';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);