re = /replace[d]?([A-Z a-z 0-9]+)with([A-Z a-z 0-9]+)/m
str = 'replaceorangeswithapples
replacebluewithred
replacecarswithbuses'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end