#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((\w+)\)|z(\w+),"
Local $sString = "Hi. (sad) I've got bad news. zsad," & @CRLF & _
"" & @CRLF & _
"Hey... (sad)" & @CRLF & _
"" & @CRLF & _
"Okay. Bye. zsad,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")