using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((\w+)\)|z(\w+),";
string input = @"Hi. (sad) I've got bad news. zsad,
Hey... (sad)
Okay. Bye. zsad,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}