re = /\((\w+)\)|z(\w+),/
str = 'Hi. (sad) I\'ve got bad news. zsad,
Hey... (sad)
Okay. Bye. zsad,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end