using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?:([^\(\)]*)|(?:(?2)(?1)(?2))*)\))";
string input = @"(asdfa(adas)(asdfad)adsafdfa ( ()()) asad (asdfasdf)asdfa)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}