package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`const ([a-zA-Z]+) = \(?[a-zA-Z,= ]+\)? =>.*`)
var str = ` const validateFadvRequestType = requestType => {
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}