re = /const ([a-zA-Z]+) = \(?[a-zA-Z,= ]+\)? =>.*/
str = ' const validateFadvRequestType = requestType => {
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end