package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\s*x\s*\d+(?:\s*x\s*\d+)?`)
var str = `120 x 80 x 100
120x80x100
120x80
120 x 80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}