// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\s*x\s*\d+(?:\s*x\s*\d+)?").unwrap();
let string = "120 x 80 x 100
120x80x100
120x80
120 x 80";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}