re = /\d+\s*x\s*\d+(?:\s*x\s*\d+)?/m
str = '120 x 80 x 100
120x80x100
120x80
120 x 80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end