const regex = /.*the(.*?)red dog.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*the(.*?)red dog.*', '')
const str = `If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}