import Foundation
let pattern = #".*the(.*?)red dog.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}