$re = '/.*the(.*?)red dog.*/';
$str = 'If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);