import re
regex = re.compile(r".*the(.*?)red dog.*")
test_str = "If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")