package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s*([^.?]*(?:how|can|what|where|describe|who|when)[^.?]*?\s*\?)`)
var str = `This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}