const regex = /\s*([^.?]*(?:how|can|what|where|describe|who|when)[^.?]*?\s*\?)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([^.?]*(?:how|can|what|where|describe|who|when)[^.?]*?\\s*\\?)', 'ig')
const str = `This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}