// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\s*([^.?]*(?:how|can|what|where|describe|who|when)[^.?]*?\s*\?)").unwrap();
let string = "This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}