$re = '/\s*([^.?]*(?:how|can|what|where|describe|who|when)[^.?]*?\s*\?)/i';
$str = 'This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);