# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w+)\b(\s\1)+/$1/g;t' <<< "Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele."