using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\b(\s\1)+";
string substitution = @"$1";
string input = @"Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}