import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w+)\\b(\\s\\1)+";
final String string = "Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}