using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (.*?) (\S+)$";
string input = @"6 Name 100/100
6 Name Name-Name 1/1001
6 Name Name`Name 1240/1422
6 Name Name`Name None";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}