re = /^(\S+) (.*?) (\S+)$/m
str = '6 Name 100/100
6 Name Name-Name 1/1001
6 Name Name`Name 1240/1422
6 Name Name`Name None'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end