package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+) (.*?) (\S+)$`)
var str = `6 Name 100/100
6 Name Name-Name 1/1001
6 Name Name\`Name 1240/1422
6 Name Name\`Name None`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}