const regex = new RegExp('^(\\S+) (.*?) (\\S+)$', 'gm')
const str = `6 Name 100/100
6 Name Name-Name 1/1001
6 Name Name\`Name 1240/1422
6 Name Name\`Name None`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}