import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " [ \\t\\n\\x0B\\f\\r]*\\{[ \\t\\n\\x0B\\f\\r]*((.|\\r|\\n)*\".*\"[ \\t\\n\\x0B\\f\\r]*:[ \\t\\n\\x0B\\f\\r]*\".*\"(.|\\r|\\n)*){0}[ \\t\\n\\x0B\\f\\r]*\\}[ \\t\\n\\x0B\\f\\r]*";
final String string = "{\n"
+ " \"location1\": \"project:bq_dataset.bq_table1\",\n"
+ " \"location10\": \"project:bq_dataset.bq_table10\",\n"
+ " \"location17\": \"project:bq_dataset.bq_table17\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}