use strict;
my $str = '{
"location1": "project:bq_dataset.bq_table1",
"location10": "project:bq_dataset.bq_table10",
"location17": "project:bq_dataset.bq_table17"
}';
my $regex = qr/ [ \t\n\x0B\f\r]*\{[ \t\n\x0B\f\r]*((.|\r|\n)*".*"[ \t\n\x0B\f\r]*:[ \t\n\x0B\f\r]*".*"(.|\r|\n)*){0}[ \t\n\x0B\f\r]*\}[ \t\n\x0B\f\r]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}